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 Important Information

Warranty
The NI 5610 and NI 5421 hardware modules are warranted against defects in materials and workmanship for a period of one year from the date 
of shipment, as evidenced by receipts or other documentation. National Instruments will, at its option, repair or replace equipment that proves 
to be defective during the warranty period. This warranty includes parts and labor. 

The media on which you receive National Instruments software are warranted not to fail to execute programming instructions, due to defects 
in materials and workmanship, for a period of 90 days from date of shipment, as evidenced by receipts or other documentation. National 
Instruments will, at its option, repair or replace software media that do not execute programming instructions if National Instruments receives 
notice of such defects during the warranty period. National Instruments does not warrant that the operation of the software shall be 
uninterrupted or error free.

A Return Material Authorization (RMA) number must be obtained from the factory and clearly marked on the outside of the package before 
any equipment will be accepted for warranty work. National Instruments will pay the shipping costs of returning to the owner parts which are 
covered by warranty.

National Instruments believes that the information in this document is accurate. The document has been carefully reviewed for technical 
accuracy. In the event that technical or typographical errors exist, National Instruments reserves the right to make changes to subsequent 
editions of this document without prior notice to holders of this edition. The reader should consult National Instruments if errors are suspected. 
In no event shall National Instruments be liable for any damages arising out of or related to this document or the information contained in it.

EXCEPT AS SPECIFIED HEREIN, NATIONAL INSTRUMENTS MAKES NO WARRANTIES, EXPRESS OR IMPLIED, AND SPECIFICALLY DISCLAIMS ANY WARRANTY OF 
MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. CUSTOMER’S RIGHT TO RECOVER DAMAGES CAUSED BY FAULT OR NEGLIGENCE ON THE PART OF 
NATIONAL INSTRUMENTS SHALL BE LIMITED TO THE AMOUNT THERETOFORE PAID BY THE CUSTOMER. NATIONAL INSTRUMENTS WILL NOT BE LIABLE FOR 
DAMAGES RESULTING FROM LOSS OF DATA, PROFITS, USE OF PRODUCTS, OR INCIDENTAL OR CONSEQUENTIAL DAMAGES, EVEN IF ADVISED OF THE POSSIBILITY 
THEREOF. This limitation of the liability of National Instruments will apply regardless of the form of action, whether in contract or tort, including 
negligence. Any action against National Instruments must be brought within one year after the cause of action accrues. National Instruments 
shall not be liable for any delay in performance due to causes beyond its reasonable control. The warranty provided herein does not cover 
damages, defects, malfunctions, or service failures caused by owner’s failure to follow the National Instruments installation, operation, or 
maintenance instructions; owner’s modification of the product; owner’s abuse, misuse, or negligent acts; and power failure or surges, fire, 
flood, accident, actions of third parties, or other events outside reasonable control.

Copyright
Under the copyright laws, this publication may not be reproduced or transmitted in any form, electronic or mechanical, including photocopying, 
recording, storing in an information retrieval system, or translating, in whole or in part, without the prior written consent of National 
Instruments Corporation.

Trademarks
CVI™, LabVIEW™, National Instruments™, NI™, ni.com™, NI Developer Zone™, and NI-DAQ™ are trademarks of National Instruments 
Corporation.

Product and company names mentioned herein are trademarks or trade names of their respective companies.

Patents
For patents covering National Instruments products, refer to the appropriate location: Help»Patents in your software, the patents.txt file 
on your CD, or ni.com/patents.

WARNING REGARDING USE OF NATIONAL INSTRUMENTS PRODUCTS
(1) NATIONAL INSTRUMENTS PRODUCTS ARE NOT DESIGNED WITH COMPONENTS AND TESTING FOR A LEVEL OF 
RELIABILITY SUITABLE FOR USE IN OR IN CONNECTION WITH SURGICAL IMPLANTS OR AS CRITICAL COMPONENTS IN 
ANY LIFE SUPPORT SYSTEMS WHOSE FAILURE TO PERFORM CAN REASONABLY BE EXPECTED TO CAUSE SIGNIFICANT 
INJURY TO A HUMAN.

(2) IN ANY APPLICATION, INCLUDING THE ABOVE, RELIABILITY OF OPERATION OF THE SOFTWARE PRODUCTS CAN BE 
IMPAIRED BY ADVERSE FACTORS, INCLUDING BUT NOT LIMITED TO FLUCTUATIONS IN ELECTRICAL POWER SUPPLY, 
COMPUTER HARDWARE MALFUNCTIONS, COMPUTER OPERATING SYSTEM SOFTWARE FITNESS, FITNESS OF COMPILERS 
AND DEVELOPMENT SOFTWARE USED TO DEVELOP AN APPLICATION, INSTALLATION ERRORS, SOFTWARE AND 
HARDWARE COMPATIBILITY PROBLEMS, MALFUNCTIONS OR FAILURES OF ELECTRONIC MONITORING OR CONTROL 
DEVICES, TRANSIENT FAILURES OF ELECTRONIC SYSTEMS (HARDWARE AND/OR SOFTWARE), UNANTICIPATED USES OR 
MISUSES, OR ERRORS ON THE PART OF THE USER OR APPLICATIONS DESIGNER (ADVERSE FACTORS SUCH AS THESE ARE 
HEREAFTER COLLECTIVELY TERMED “SYSTEM FAILURES”). ANY APPLICATION WHERE A SYSTEM FAILURE WOULD 
CREATE A RISK OF HARM TO PROPERTY OR PERSONS (INCLUDING THE RISK OF BODILY INJURY AND DEATH) SHOULD 
NOT BE RELIANT SOLELY UPON ONE FORM OF ELECTRONIC SYSTEM DUE TO THE RISK OF SYSTEM FAILURE. TO AVOID 
DAMAGE, INJURY, OR DEATH, THE USER OR APPLICATION DESIGNER MUST TAKE REASONABLY PRUDENT STEPS TO 
PROTECT AGAINST SYSTEM FAILURES, INCLUDING BUT NOT LIMITED TO BACK-UP OR SHUT DOWN MECHANISMS. 
BECAUSE EACH END-USER SYSTEM IS CUSTOMIZED AND DIFFERS FROM NATIONAL INSTRUMENTS' TESTING 
PLATFORMS AND BECAUSE A USER OR APPLICATION DESIGNER MAY USE NATIONAL INSTRUMENTS PRODUCTS IN 
COMBINATION WITH OTHER PRODUCTS IN A MANNER NOT EVALUATED OR CONTEMPLATED BY NATIONAL 
INSTRUMENTS, THE USER OR APPLICATION DESIGNER IS ULTIMATELY RESPONSIBLE FOR VERIFYING AND VALIDATING 
THE SUITABILITY OF NATIONAL INSTRUMENTS PRODUCTS WHENEVER NATIONAL INSTRUMENTS PRODUCTS ARE 
INCORPORATED IN A SYSTEM OR APPLICATION, INCLUDING, WITHOUT LIMITATION, THE APPROPRIATE DESIGN, 
PROCESS AND SAFETY LEVEL OF SUCH SYSTEM OR APPLICATION.
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About This Manual

This guide explains how to install, configure, test, and begin using the 
NI 5670 RF Vector Signal Generator. Additional documents such as the 
NI 5670  Help (which includes the NI-RFSG instrument driver 
LabVIEW VI and LabWindows™/CVI™ function reference help), 
the NI 5670 Hardware User Manual, and NI PXI-5670 Specifications 
documents are accessible from Start»Programs»National Instruments» 
NI-RFSG»Documentation.

For free downloads of the most current versions of drivers, documentation, 
and example programs, refer to ni.com/instruments.

Conventions
The following conventions are used in this manual:

» The » symbol leads you through nested menus to a final action. The 
sequence File»Page Setup»Options directs you to pull down the File 
menu, select the Page Setup item, and select Options from the last dialog 
box.

This icon denotes a tip, which alerts you to advisory information.

This icon denotes a note, which alerts you to important information.

This icon denotes a caution, which advises you of precautions to take to 
avoid injury, data loss, or a system crash.

bold Bold text denotes items that you must select or click in the software, such 
as menu items and dialog box options. Bold text also denotes parameter 
names.

italic Italic text denotes variables, emphasis, a cross reference, or an introduction 
to a key concept. This font also denotes text that is a placeholder for a word 
or value that you must supply.

monospace Text in this font denotes text or characters that you enter from the keyboard. 
This font is also used for the proper names of paths, directories, programs, 
functions, operations, variables, and filenames.

www.ni.com/instrument
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Key Terms
AWG Arbitrary Waveform Generator—refers to the NI 5421 arbitrary waveform 

generator hardware module.

module Refers to one of the hardware components of the NI 5670: the NI 5421 
arbitrary waveform generator or the NI 5610 wideband RF upconverter.

PLL Phase-Locked Loop—an electronic circuit that controls an oscillator so that 
the circuit maintains a constant phase angle relative to a reference signal.

RF Radio Frequency—refers to the signal output from the RF OUTPUT 
connector on the NI 5670 device front panel.

upconverter A device that frequency-translates baseband signals to center around a 
specified RF frequency—refers to an NI 5610 2-slot RF upconverter 
hardware module.
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1
Getting Started with the NI 5670

NI 5670 Overview
The NI PXI-5670 is a modular RF signal source consisting of two PXI 
hardware modules:

• NI PXI-5421—16 bit, 100 megasample-per-second (MS/s) arbitrary 
waveform generator (AWG) module (400 MS/s interpolated).

• NI PXI-5610—2.7 GHz RF superheterodyne upconverter module with 
input frequencies between 15 and 35 MHz.

The hardware modules interconnect using the included SMA-SMB coaxial 
cables as illustrated in the Interconnecting NI 5670 Modules section.

Note There is no single physical device labeled “NI PXI-5670.” The NI 5670 is the 
instrument comprised of the two hardware modules (NI 5610 and NI 5421) and the 
NI-RFSG instrument driver.

The NI 5670 has the following characteristics and features:

• 250 kHz to 2.7 GHz frequency range

• 20 MHz real-time bandwidth

• 10 MHz oven-controlled crystal oscillator (OCXO) timebase

– ±20 ppb frequency stability

– ±50 ppb frequency accuracy

• 132 dB compression-to-noise dynamic range

• ≤–119 dBm/Hz typical noise density

• Up to 256 MB of onboard waveform memory

• NI-RFSG instrument driver software operates both modules as a single 
transparent unit.

• Three slots wide PXI/3U Compact PCI form factor

The NI 5670 follows industry-standard Plug and Play specifications for the 
PXI bus and can be seamlessly integrated with compliant systems.
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NI 5610 Upconverter Module
The NI 5610, shown in Figure 1-1, is a 250 kHz to 2.7 GHz 
superheterodyne upconverter hardware module. It offers 20 MHz real-time 
bandwidth and a highly accurate oven-controlled crystal oscillator (OCXO) 
frequency reference that can be software-configured to drive the PXI 
10 MHz backplane clock when the NI 5610 is installed in PXI Slot 2. 

Figure 1-1.  NI 5610 RF Upconverter Module

Tip The NI 5610 upconverter module (two slots wide) is installed in the leftmost of its 
two occupied PXI slots. Thus, installing the NI 5610 module in PXI Slot 2, for instance, 
occupies PXI Slots 2 and 3. Slot numbers are printed on the PXI chassis.
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NI 5421 AWG Module
The NI 5421, shown in Figure 1-2, is a single-channel 16-bit 100 MS/s 
AWG hardware module. 

Figure 1-2.  NI 5421 AWG Module

Refer to
 Documentation for In

stallation
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Verifying System Requirements

Minimal System
Before installing the NI 5670 hardware and software, verify that your PXI 
system meets the following requirements: 

• Pentium IV or comparable processor

• Windows 2000/NT/XP

• 3 GB of free hard drive space

• 256 MB of RAM

Recommended System
For optimal performance with large waveforms, NI recommends that your 
PXI system meet the following requirements:

• Pentium IV or comparable processor

• Windows 2000/NT/XP

• 3 GB of free hard drive space

• 1 GB of RAM

Application Development Software
If you are developing applications, your system must include one of the 
following installed application development environments (ADEs) and 
associated documentation:

• NI LabVIEW 7.0 or later, Full Development System or Professional 
Development System

• LabWindows/CVI 6.0 or later

Note RAM requirements vary by application. Every 220 samples of complex I-Q data 
require 8 MB of RAM. You may be able to substitute virtual memory for RAM depending 
on system speed and application needs.
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Unpacking
Both hardware modules of the NI 5670 ship in antistatic packages to 
prevent damage from electrostatic discharge (ESD). Because ESD can 
damage several components of both NI 5670 hardware modules, store both 
modules in the antistatic envelopes when not in use.

Caution Never touch exposed connector pins.

To avoid damage in handling the NI 5670 hardware modules, take the 
following precautions:

• Ground yourself using a grounding strap or by touching a grounded 
object.

• Touch the antistatic package to a metal part of your computer chassis 
before removing the hardware module from the package.

Remove each hardware module from the package and inspect it for loose 
components or any signs of damage. Notify NI if either hardware module 
appears damaged in any way. Do not install a damaged module into your 
system.
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Verifying Kit Contents
In addition to this guide, you need the following items to set up and use the 
NI 5670 RF Vector Signal Generator:

❑ NI-RFSG CD—installs the following software components:

– NI-RFSG instrument driver

– NI-RFSG examples, intended for use as interactive applications, 
instructional models, or building blocks in your own applications

– Hardware and software documentation

❑ The following hardware components, as shown in Figure 1-3.

– Two hardware modules:

• NI 5421 AWG module.

• NI 5610 wideband upconverter module.

– A PXI chassis with at least three empty slots (not included). 
NI recommends an NI PXI-1042 chassis.

– A PXI embedded or MXI-3 controller system (not included) that 
meets the system requirements specified in this guide.

– Two semi-flexible SMA-to-SMB coaxial cables.

– 1/8-in. combination Phillips/flathead screwdriver.

– Plastic collars (cable wrenches) for gripping the coaxial cable hex 
connectors.

– A 100 N-cm standard SMA torque wrench (not included).
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Figure 1-3.  NI 5670 Required Parts Inventory and Replacement Part Numbers

1 NI PXI-1042 Chassis (not included)
2 NI 5421 AWG Module
3 NI 5610 Upconverter Module
4 SMA-to-SMB Coaxial Cables (2)

5 Cable Wrenches (2)
6 Screwdriver
7 100 N-cm SMA Torque Wrench (not included)

1 2 3

NI PXI-5610

RF Upconverter 250 kHz - 2.7 GHz

INPUT

REF OUT

REF IN

RF OUTPUT

± 5V DC MAX

+16 dBm MAX

TO AWGCLK IN

PLL STATUS

ACCESS

NI PXI-1042

PFI 0

PFI 1

NI PXI-5421

16-Bit 100 MS/s AWG 
ACCESS

ACTIVE

CLK
IN

CH 0 LOCAL
 OSC OUT 0

74 5 6

190846A-01 746016-01 772006-01

188079B-01 189898A-01 189718D-01
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Installing the Software
Complete the following steps to install the contents of the NI-RFSG CD:

1. Install a development environment such as NI LabVIEW and/or 
LabWindows/CVI according to its instructions. Any development 
environment you intend to use must be installed before you install the 
NI-RFSG CD.

2. Install the contents of the NI-RFSG software CD by navigating to your 
CD drive and clicking setup.exe. 

3. Install any toolkits or other optional add-on software you intend to use 
with the NI 5670.

Note You must install the NI-RFSG CD before installing any add-on software you intend 
to use with the NI 5670. If add-on products are already installed, repeat or repair those 
installations after installing the NI-RFSG CD.

Installing the Hardware

PXI Slot Location
Installation of both NI 5670 hardware modules requires three vacant PXI 
slots—two slots for the NI 5610 upconverter module and one slot for the 
NI 5421 AWG module. The NI 5421 AWG module must be installed in the 
adjacent slot immediately to the right of the NI 5610 upconverter module 
to use the included SMA-to-SMB coaxial cables.

Note The NI 5670 specifications assume use of the included cables. Substituting different 
cables may affect performance.

The NI 5610 upconverter module onboard frequency reference can drive 
the PXI backplane clock only if the upconverter module is installed in PXI 
Slot 2. When the NI 5610 is installed in PXI Slot 2, you can configure it to 
lock the PXI backplane to the NI 5610 onboard oven-controlled crystal 
oscillator or to an external frequency source (connected to the REF IN 
connector on the NI 5610 module front panel).

Tip The NI 5610 upconverter module (two slots wide) is installed in the leftmost of its 
two occupied PXI slots. Thus installing the NI 5610 module in PXI Slot 2 occupies 
PXI Slots 2 and 3. Slot numbers are printed on the PXI chassis. 
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NI 5610 Upconverter Module Installation
Install the NI 5610 RF upconverter module by completing the following 
steps:

1. Power off your PXI chassis.

2. Install the NI 5610 upconverter module as shown in Figure 1-4. This 
module requires two vacant PXI slots. 

Note The NI 5610 must be installed in PXI Slot 2 to optionally drive the PXI backplane 
with the NI 5610 onboard oven-controlled crystal oscillator or an external reference signal.

a. Remove the black plastic protectors from the four captive screws 
in the module front panel.

b. Slide the NI 5610 into an available PXI slot until the ejector 
handle locks in the upward position.

c. Tighten the four screws in the module front panel.
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Figure 1-4.  Install the NI 5610 Upconverter Module

1 PXI Chassis
2 Remove Rubber Screw Covers

3 NI 5610 Upconverter Module
4 Ejector Handle in Down Position

1

3

2

4
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NI 5421 AWG Module Installation
Install the NI 5421 AWG module in the adjacent PXI slot immediately to 
the right of the NI 5610 upconverter module by completing the following 
steps:

1. Ensure that your PXI chassis is powered off.

2. Install the NI 5421 AWG module as shown in Figure 1-5.

a. Remove the black plastic protectors from the two captive screws 
in the module front panel.

b. Slide the NI 5421 into the slot immediately to the right of the 
NI 5610 upconverter module. Press firmly until the ejector handle 
locks in the upright position.

c. Tighten both screws in the NI 5421 front panel.

Figure 1-5.  Install the NI 5421 AWG Module

1 PXI Chassis
2 NI 5421 AWG Module

3 Remove Rubber Screw Covers
4 Ejector Handle in Down Position

NI PXI-1042

NI PXI-5610

RF Upconverter 250 kHz - 2.7 GHz

INPUT

REF OUT

REF IN

RF OUTPUT

± 5V DC MAX

+16 dBm MAX

TO AWGCLK IN

PLL STATUS

ACCESS

PFI 0

PFI 1

NI PXI-5421

16-Bit 100 MS/s AWG 
ACCESS

ACTIVE

CLK
IN

CH 0

D
IG

IT
A

L
 D

A
T

A
 &
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O

N
T

R
O

L

1

3

2

4
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3. Continue with the procedure in the Interconnecting NI 5670 Modules 
section once you have read and understood the Cooling section.

Cooling

Caution The NI 5610 front panel may become warm to the touch during normal operation, 
and caution should be used when removing and handling a recently used module. 

The NI 5610 operates at internal temperatures of about 45 °C (113 °F) 
under conditions of proper air flow and 25 °C (63 °F) ambient 
temperatures.

Caution Inadequate air circulation could cause the temperature inside the chassis to rise 
above the optimal operating temperature for the NI 5670, potentially causing thermal 
shutdown, shorter lifespans, or improper performance. 



Chapter 1 Getting Started with the NI 5670

© National Instruments Corporation 1-13 NI 5670 RF Vector Signal Generator Getting Started Guide

Use the following guidelines to help maintain optimal forced-air cooling 
within the PXI chassis:

• Install all chassis covers and filler panels after installing your NI 5670 
modules, as shown in Figure 1-6. Missing filler panels disrupt the 
necessary air circulation in the chassis.

Figure 1-6.  Install All PXI Filler Panels after Hardware Installation

• Allow plenty of space around the vents at the rear of the chassis. 
Blockage by walls or obstructions affects the air flow needed for 
cooling.

• Set all chassis fans to the highest possible setting. Do not set the fan 
speed to LOW or turn the fan off.

• Clean the fan filters on a regular basis to avoid fan and air circulation 
path blockage. Refer to your chassis documentation for cleaning 
procedures and other recommended maintenance.

NI PXI-1042
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• (Optional) NI recommends installing slot blockers to maximize 
cooling air flow. The PXI Chassis Slot Blocker Kit, part number 
778678-01, is shown in Figure 1-7.

Figure 1-7.  Optional Slot Blockers Enhance Cooling

Overtemperature Shutdown
If the temperature of either module exceeds specifications, the instrument 
is disabled and the NI-RFSG driver software notifies you with a thermal 
shutdown error message. 

To re-enable the NI 5670 after thermal shutdown, you must perform a 
device reset on each module in Measurement & Automation Explorer 
(MAX) or call the niRFSG Reset Device VI (niRFSG_resetDevice 
function) to reset both modules. Continue to the Configuring the NI 5670 
Modules in MAX section for more information about using MAX.

1 PXI Slot Blocker 2 Remove Rubber Screw Covers

2

1
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Interconnecting NI 5670 Modules
The NI 5670 hardware modules interconnect through the front panels. 
Complete the following steps to interconnect the NI 5670 hardware module 
front panel connectors as shown in Figure 1-8.

1. Connect the INPUT connector on the NI 5610 upconverter module to 
the CH 0 connector on the NI 5421 AWG module. 

2. Connect the TO AWG CLK IN connector on the NI 5610 upconverter 
module to the CLK IN connector on the NI 5421 AWG module.
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Figure 1-8.  Proper Interconnection of the NI 5670 Front Panels

3. Carefully tighten all SMA connectors to 100 N-cm using an SMA 
torque wrench (not included) as shown in Figure 1-9. Tighten only 
until the wrench clicks.

Caution Incorrect torque at SMA connections can degrade signal fidelity, 
PLL performance, and insertion loss. Use an SMA torque wrench to ensure all SMA 
connections are properly torqued to 100 N-cm.
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Figure 1-9.  Torque All SMA Connectors to 100 N-cm

4. Power up your PXI chassis and controller system.

5. Verify that the ACCESS LED on both modules is illuminated. If the 
LEDs are not illuminated, refer to Appendix B, Troubleshooting.

Hold Here,
Tighten Gently Until Wrench Clicks

100 N-cm SMA
Torque Wrench
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Configuring the NI 5670 Modules in MAX
Measurement & Automation Explorer (MAX) is used to configure your 
National Instruments hardware. MAX informs other programs about which 
devices reside in the system and how they are configured. MAX is 
automatically installed with the NI-RFSG driver. 

Note MAX treats the NI 5610 upconverter module and the NI 5421 AWG module as 
separate but associated devices. The MAX association is necessary for transparent 
operation of both modules as a single instrument (the NI 5670) using the NI-RFSG driver. 

To use MAX to configure, self-test, associate, and generate signals with the 
NI 5670 hardware modules, complete the following steps:

1. Launch MAX by navigating to Start»Programs»
National Instruments»Measurement & Automation or by clicking 
the MAX desktop icon.

2. In the Configuration pane, double-click Devices and Interfaces to see 
the list of installed devices. 

3. Expand the NI-DAQmx Devices folder. You will see a list of installed 
devices that includes the NI 5610 and NI 5421 modules, as shown in 
Figure 1-10 (your default device names may vary).

Figure 1-10.  Both Modules Appear in MAX

Note If you do not see the NI PXI-5421 and NI PXI-5610 modules listed, refer to 
Appendix B, Troubleshooting.
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Rename Both Modules
MAX allows you to rename both NI 5670 hardware modules with names 
of your choice. The name you specify in MAX is used in software to 
operate the NI 5670 hardware resources. You do not have to change your 
module names from the default, but doing so can make programming 
easier.

To rename both NI 5670 hardware modules, complete steps 4 through 10.

4. Right-click the NI 5610 upconverter module and select Rename from 
the shortcut menu as shown in Figure 1-11.

Figure 1-11.  Rename the NI PXI-5610 Upconverter Module

5. Type the new name for the NI 5610 upconverter module.

6. Click OK.

Note The device name cannot duplicate a module type. For example, MAX cannot 
rename a module as NI PXI-5610. Choose descriptive names such as Upconverter or 
AWG instead.
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7. Right-click the NI 5421 AWG module and select Rename from the 
shortcut menu as shown in Figure 1-12.

Figure 1-12.  Rename the NI PXI-5421 AWG Module

8. Type the new name for the NI 5421 AWG module. The new device 
name cannot begin with NI PXI-.

9. Click OK. 

10. Verify that the new names for both modules are displayed as the 
example in Figure 1-13 shows before proceeding to step 11.

Figure 1-13.  Renamed NI 5670 Hardware Modules
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Self-Test Both Modules
The MAX self-test performs a basic verification of hardware resources. 
Complete steps 11 through 14 to self-test both modules.

11. Right-click the NI PXI-5610 and select Self-Test, as shown in 
Figure 1-14.

Figure 1-14.  Select Self-Test from the NI PXI-5610 Right-Click Menu

12. The Success dialog appears as shown in Figure 1-15. Click OK to 
return to MAX.

Figure 1-15.  Self-Test Result for the NI 5610 Upconverter Module

Note If the NI 5610 upconverter module fails the self-test, refer to Appendix B, 
Troubleshooting.
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13. Right-click NI PXI-5421 and select Self-Test, as shown in 
Figure 1-16.

Figure 1-16.  Select Self-Test from the NI PXI-5421 Right-Click Menu

14. The Success dialog appears as shown in Figure 1-17. Click OK to 
return to MAX.

Figure 1-17.  Self-Test Result for the NI 5421 AWG Module

Note If the NI 5421 AWG module fails the self-test, refer to Appendix B, 
Troubleshooting.
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Associate an NI 5421 AWG Module
You must create a MAX association between the NI 5610 and the 
NI 5421 to control both hardware modules as a single instrument. 
Complete steps 15 through 17 to make this association. 

15. Right-click NI PXI-5610 and select Properties as shown in 
Figure 1-18. 

Figure 1-18.  Select Properties from the NI PXI-5610 Right-Click Menu
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16. In the NI 5610 Device Properties dialog (Figure 1-19), use the 
drop-down listbox to specify the NI 5421 AWG module that is 
connected to the NI 5610 by front panel coaxial cables. Refer to the 
Interconnecting NI 5670 Modules section for more information.

Tip You must repeat this association if you rename the NI 5421 AWG module after 
association. Remember to reassociate the NI 5670 hardware modules if you rename the 
NI 5421 AWG module.

Figure 1-19.  Associate an AWG in the NI 5610 Device Properties Dialog

17. Click OK to return to MAX.
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Run the NI 5670 Test Panel
The NI 5670 test panel tests both hardware modules as a single instrument. 
Complete steps 18 through 24 to use the NI 5670 test panel.

Note This test requires front panel interconnection as shown in Figure 1-8 and the 
association of an NI 5421 AWG module with an NI 5610 upconverter module as described 
in steps 15 through 17. 

18. Right-click the NI PXI-5610 upconverter module and select Test 
Panels as shown in Figure 1-20. 

Figure 1-20.  Right-Click NI PXI-5610 to Open the NI 5670 Test Panel
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19. In the NI PXI-5670 tab of the Test Panels dialog, specify a frequency 
and a power level for signal generation as shown in Figure 1-21.

Figure 1-21.  The NI PXI-5670 RF Vector Signal Generator Test Panel

20. This panel verifies that the NI 5670 is locking to the reference clock 
and generating a signal. Click Start to begin signal generation. 

Tip Running the test panel outputs a signal from the RF OUTPUT front panel connector. 
Disconnect any equipment that may be damaged by the test signal.
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21. During signal generation the ACTIVE LEDs on both NI 5670 
hardware modules are activated and the test panel is displayed as 
shown in Figure 1-22.

Note If either ACTIVE LED does not illuminate or if the NI 5670 test panel generates an 
error, refer to Appendix B, Troubleshooting.

Figure 1-22.  The NI PXI-5670 Test Panel during Signal Generation

22. Click Stop to halt waveform generation.

23. Click Close to return to MAX. 

24. Exit MAX. 

You have completed setup, configuration, and testing of the NI 5670 RF 
Vector Signal Generator.
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Introduction to the NI-RFSG Driver
The NI-RFSG instrument driver software controls all NI 5670 
configuration and operation using LabVIEW VIs or LabWindows/CVI 
functions. The NI-RFSG instrument driver transparently operates the 
NI 5610 upconverter module and the NI 5421 AWG module as a single 
instrument (the NI 5670). The modules are associated as a single 
instrument in MAX (refer to the Configuring the NI 5670 Modules in MAX 
section for more information).

The NI-RFSG driver configures and operates the NI 5670 hardware, 
performs waveform programming and generation, and is capable of basic 
IQ modulation tasks. Optional add-on software available from NI, 
including the Modulation Toolkit and the Spectral Measurements Toolkit, 
extends the capability of the NI 5670 to include additional 
frequency-domain and modulation-domain tasks.

The simple hardware/software hierarchy of the NI 5670 is shown in 
Figure 1-23.

Figure 1-23.  NI-RFSG Programming Flow

Application Development Environment

NI 5421 NI 5610

RFSG Hardware

NI-RFSG Driver

LabVIEW LabWindows/CVIand/or
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Note Refer to the NI 5670 Help or the NI 5670 Hardware User Manual for a more 
hardware/software hierarchy diagram. Both documents are installed at Start»Programs»
National Instruments»NI-RFSG»Documentation.

NI-RFSG Programming Flow
NI-RFSG VIs are located on the LabVIEW function palette at 
Instrument I/O»Instrument Drivers»NI-RFSG. The top-level 
NI-RFSG functions palette is shown in Figure 1-24.

Tip Refer to the interactive version of this walkthrough in the NI-5670 Help for more 
information and for help finding NI-RFSG VIs on the LabVIEW palette. The NI 5670 Help 
is installed at Start»Programs»National Instruments»NI-RFSG»Documentation.

Figure 1-24.  NI-RFSG LabVIEW Palette. Core VIs are Highlighted.

Note Every application using NI-RFSG must call the five VIs highlighted in the palette 
image above. 
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These VIs are arranged from left to right in the order they must be called:

NI-RFSG Example Applications
NI-RFSG includes several example applications for both LabVIEW and 
LabWindows/CVI. These examples are intended to serve as interactive 
tools, programming models, and building blocks in your own applications. 

With LabVIEW running, select Help»Find Examples to launch the 
LabVIEW Example Finder. The Example Finder offers two ways to access 
all installed LabVIEW example VIs and their descriptions: 

• Click the Browse tab to locate NI-RFSG examples by task at 
Hardware Input and Output»Modular Instruments» NI-RFSG or 
by directory structure at instr»niRFSG. 

• Click the Search tab to search all installed examples by keyword. 
Enter the keyword FM, for instance, to locate an example 
demonstrating FM signal generation using the NI 5670 and the 
NI Modulation Toolkit (if installed).

LabVIEW and LabWindows/CVI users also can access all the installed 
NI-RFSG examples at Start»Programs»National Instruments» 
NI-RFSG»Examples. View LabVIEW examples by navigating to the 
<LabVIEW home>\examples\instr\niRFSG folder. View examples 
for CVI by navigating to the <Program Files>\IVI\Drivers\

niRFSG\Examples\CVI directory.

1. niRFSG Initialize—Opens a session to the NI 5670 
hardware modules and initializes both the 
NI 5421 AWG and the NI 5610 upconverter modules.

2.  niRFSG Configure RF—Configures the frequency 
and power level of the RF output signal. 

3. niRFSG Initiate—Initiates signal generation. After 
calling this function, the RF output signal is settled.

4. niRFSG Check Generation Status—Monitors 
signal generation status and verifies correct hardware 
and software operation during signal generation.

5. niRFSG Close—Closes the niRFSG session, and 
deallocates memory resources used by NI-RFSG. 
You must call this VI once for every NI-RFSG session 
opened with niRFSG Initialize.
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Examples also are available online at ni.com/examples that 
demonstrate integrating the NI 5670 RF Signal Generator with the 
NI 5660 RF Signal Analyzer and NI toolkit software including the 
Modulation Toolkit. Refer to the NI Developer Zone on the Web at 
ni.com/examples for these examples and more information.

Building a Basic NI-RFSG Application
Complete the following steps in LabVIEW to build a basic NI-RFSG 
application for generating continuous sine wave signals:

1. Select Start»Programs»National Instruments»LabVIEW 7» 
LabVIEW to launch LabVIEW. The LabVIEW dialog appears.

2. Click New, choose Blank VI, and click OK to create a blank VI.

3. Display the block diagram by clicking it or by selecting 
Window»Show Block Diagram.

4. Activate the LabVIEW context help by pressing <Ctrl-H>. 

5. Navigate to the NI-RFSG VIs on the Functions»Instrument I/O»
Instrument Drivers»NI-RFSG palette.

6. Create the block diagram shown in Figure 1-25 by wiring the five core 
VIs on the block diagram in the order they appear in the top row of the 
NI-RFSG functions palette.

Figure 1-25.  Basic NI-RFSG Block Diagram

7. Hover the cursor over the resource name terminal on the 
niRFSG Initialize VI and right-click. Select Create»Control to create 
a front panel field where you specify the NI 5670 device name. The 
resource name terminal is highlighted in Figure 1-26.

Figure 1-26.  Resource Name Terminal on niRFSG Initialize VI
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8. Hover the mouse tool over the frequency (Hz) and 
power level (dBm) terminals of the niRFSG Configure RF VI. 
These terminals are highlighted in Figure 1-27. 

Figure 1-27.  Frequency and Power Level Terminals on the niRFSG Configure RF VI 

9. Right-click each terminal and select Create»Control from the 
shortcut menu to create frequency and power controls as shown in 
Figure 1-28.

Figure 1-28.  Frequency and Power Level Controls on the Block Diagram

10. Display the VI front panel by clicking it or by selecting Window»
Show Front Panel. Fields are displayed in which you can specify a 
frequency and power level.

11. In the VI front panel power level (dBm) field, type 0. In the 
frequency (Hz) field, type 100M (100 MHz).

12. In the VI front panel resource name field, type the NI 5610 
upconverter module name that you specified in MAX. The NI 5610 
upconverter module must be associated with a NI 5421 AWG module. 
Refer to the Configuring the NI 5670 Modules in MAX section for more 
information.

Continous waveform generation is controlled by means of a STOP button.  
A STOP button is typically used within a While Loop. This example places 
a While Loop around the Check Generation Status VI so that signal 
generation continues and waveform status is continuously checked until 
you click STOP. 
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Build a STOP button by completing steps 13 through 17.

13. Display the block diagram by clicking it or selecting Window»
Show Block Diagram.

14. Select the While Loop on the All Functions»Structures palette.

15. Enclose the niRFSG Check Generation Status VI in the While Loop, 
as shown in Figure 1-29. 

Figure 1-29.  Enclose niRFSG Check Generation Status VI in the While Loop

16. Hover the mouse tool over the Loop Condition terminal of the While 
Loop. The terminal is highlighted in Figure 1-30. 

Figure 1-30.  Loop Condition Terminal on While Loop
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17. Right-click the Loop Condition terminal and select Create Control 
from the shortcut menu to create a STOP button on the VI front panel. 
The resulting portion of the block diagram is shown in Figure 1-31.

Figure 1-31.  While Loop with STOP Button

Complete steps 18 through 19 to add an error indicator to your VI front 
panel: 

18. Create an error indicator by right-clicking the error out terminal of the 
niRFSG Close VI and selecting Create»Indicator. The error out 
terminal is highlighted in Figure 1-32.

Figure 1-32.  Error Out Terminal on niRFSG Close VI
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19. Verify that your VI block diagram now looks like the example in 
Figure 1-33.

Figure 1-33.  Basic Sine Wave Generation VI Block Diagram
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20. Display the VI front panel by clicking it or by selecting Window»
Show Front Panel. Verify that your VI front panel looks like the 
example in Figure 1-34.

Figure 1-34.  Basic Sine Wave Generation VI Front Panel

Note The resource name control is populated with the NI 5610 upconverter module 
name specified in MAX; refer to the Rename Both Modules section for more information.

21. Click the RUN icon on the VI taskbar to initiate sine wave generation. 

22. Click the VI front panel STOP button to stop sine wave generation.

Caution Always stop VI operation using the front panel STOP button you created. 

Never stop a VI with the ABORT button on the taskbar. The ABORT button does not free
memory resources and leaves hardware and software in an unknown state.

You have successfully generated a continuous sine wave signal using the 
NI-RFSG driver software and the NI 5670 hardware. 



Chapter 1 Getting Started with the NI 5670

© National Instruments Corporation 1-37 NI 5670 RF Vector Signal Generator Getting Started Guide

Help for Other Tasks
With LabVIEW running, select NI 5670 Help from the Help pull-down 
menu. The NI 5670 Help contains hardware and software reference 
information and instructions for performing common RF signal generation 
tasks. 

You also can access the NI 5670 Help from Start»Programs»
National Instruments»NI-RFSG»Documentation.
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A
Hardware Front Panel 
Connectors and Indicators

These sections describe the connectors and LED indicators on the front 
panels of both NI 5670 hardware modules. All inputs and outputs are 
AC-coupled.

NI 5610 Upconverter Module
The NI 5610 upconverter module front panel contains six connectors and 
two multicolor LEDs, as shown in Figure A-1.

Figure A-1.  NI 5610 Upconverter Module Front Panel
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Table A-1.  NI 5610 RF Upconverter Module Front Panel Connectors

Connector Use 

10 MHz OUT
(TO AWG CLK IN)

Connect the TO AWG CLK IN connector to the CLK IN connector on 
the NI 5421 module front panel.

Both connectors output replications of the upconverter 10 MHz 
frequency reference signal, useful for driving other devices. Each 
replication is 180 degrees out-of-phase with the other. The signal 
output at these connectors is always on and cannot be disabled.

10 MHz OUT

REF IN Routes an external frequency reference signal that can be propagated to 
the PXI backplane. The NI 5610 can lock to this signal.

IF INPUT Connect to the CH 0 output on the NI 5421 front panel.

Routes the IF signal from the NI 5421 AWG module for frequency 
translation.

LOCAL OSC OUT 0 Outputs the auxiliary local oscillator signal. 

RF OUTPUT Outputs the upconverted signal at the requested RF frequency.

Table A-2.  NI 5610 RF Upconverter Module Front Panel LEDs

LED Indications

ACCESS Indicates the basic hardware status of the NI 5610 module. This LED functions 
identically to the ACCESS LED on the AWG module front panel.

OFF—The module is not yet functional, or has detected a problem with a PXI 
power rail.

AMBER—The module is being accessed.

GREEN—The module is ready to be programmed.

ACTIVE Indicates the status of the NI 5610 PLLs.

OFF—The module is in an uninitialized state; there is no error.

AMBER—The module PLLs are attempting to lock.

GREEN—The module is in a ready state; applicable PLLs are locked and the 
reverse power protection circuit is closed.

RED—The module has detected an error state; this may indicate an overload 
(reverse power protection circuit is open), lock failure in an applicable PLL, 
a self-test or calibration failure, or a thermal shutdown condition. 
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NI 5421 AWG Module
The front panel of the NI 5421 AWG module contains five connectors and 
two multicolor LEDs, as shown in Figure A-2. 

Figure A-2.  NI 5421 AWG Module Front Panel

Table A-3.  NI 5421 AWG Module Front Panel Connectors

Connector Use 

CH 0 Outputs an IF waveform for upconversion to the desired RF frequency. 

Connect to the IF INPUT connector on the NI 5610 front panel. 

CLK IN Inputs the NI 5421 internal reference clock signal.

Connect to the REF OUT connector on the NI 5610 module front panel. 

PFI 0 Bidirectional SMB connectors. As an input, the PFI terminals can accept 
a trigger from an external source to start or step through signal 
generation.PFI 1
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Table A-4.  NI 5421 AWG Module Front Panel LEDs

LED Indications

ACCESS Indicates the basic hardware status of the NI 5421 AWG module. This LED 
functions identically to the ACCESS LED on the NI 5610 upconverter module 
front panel.

OFF—The module is not yet functional, or has detected a problem with 
a power rail.

AMBER—The module is being accessed.

GREEN—The module is ready to be programmed.

ACTIVE Indicates the state of the NI 5421 AWG module.

OFF—The module is not armed or triggered.

AMBER—The module is armed and waiting for a Start trigger.

GREEN—The module has received a Start trigger and is generating 
a waveform.

RED—The module has detected an error state; this may indicate PLL 
unlocking, self-test failure, or calibration failure.
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B
Troubleshooting

This section discusses issues you may encounter during installation of the 
NI 5670 RF Vector Signal Generator hardware and software. You also can 
refer to the Troubleshooting section of the NI 5670 Hardware User 
Manual, accessible from Start»Programs»National Instruments»
NI-RFSG»Documentation.

Module Front Panel ACCESS LED is Off When PXI 
Chassis is On

If the ACCESS LED fails to light, a problem may exist with the PXI power 
rail, a hardware module, or the LED. Complete the following steps to 
troubleshoot this issue:

1. Power off your PXI chassis.

2. Remove any module front panel interconnections between the NI 5670 
modules.

3. Remove the NI 5670 hardware modules and inspect for damage. 
Do not reinstall a damaged device.

4. Reinstall both NI 5670 hardware modules in different PXI slots. 
Use the procedure detailed in the Installing the Hardware section of 
Chapter 1, Getting Started with the NI 5670.

5. Power on your PXI chassis. 

6. If either ACCESS LED still fails to light, and failures continue, contact 
NI technical support at ni.com/ask or call 866-275-6964 and ask to 
speak to a customer service representative.
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Hardware Module Does Not Appear in MAX
Use the following procedure if either NI 5670 hardware module does not 
appear in MAX:

1. In the MAX Configuration pane, click the NI-DAQmx Devices folder 
and press <F5> to refresh the list of installed devices.

2. If either module is still not listed, power off the system, ensure the 
NI 5670 hardware is correctly installed, and restart the system.

3. Open the Windows Control Panel and select System»Hardware»
Device Manager. Complete the appropriate step for your setup:

• If using a PXI controller, verify that a National Instruments 
entry appears in the system device list. Reinstall NI-RFSG and the 
NI 5670 hardware modules if error conditions are present in the 
list.

• If using a MXI-3 controller, right-click PCI-to-PCI Bridge and 
select Properties from the shortcut menu to verify that the bridge 
is enabled. 

4. If either module still fails to appear in the MAX NI-DAQmx Devices 
folder, contact NI technical support at ni.com/ask or call 
866-275-6964 and ask to speak to a customer service representative.

A Module Fails the Self-Test
The MAX self-test performs a brief test of device resources. If either 
module of the NI 5670 hardware does not pass the self-test, complete the 
following steps:

1. Reboot your system.

2. Launch MAX and perform the self-test again. If the module still fails 
the self-test, proceed to step three.

3. Uninstall the NI-RFSG driver software using the Add/Remove 
Programs option on the Windows Control Panel. Never attempt to 
uninstall by deleting files.

4. Reinstall NI-RFSG by running setup.exe on the NI-RFSG CD.

5. If either module still fails the self-test, contact NI technical support at 
ni.com/ask or call 866-275-6964 and ask to speak to a customer 
service representative.
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The NI 5670 Test Panel Fails
The NI 5670 test panel tests both hardware modules as a single instrument. 
If the test panel fails or generates an error, complete the following steps to 
locate the problem:

1. Verify that both NI 5670 modules are interconnected through the 
module front panels as shown in Figure 1-8, Proper Interconnection of 
the NI 5670 Front Panels, of Chapter 1, Getting Started with the 
NI 5670. 

2. Ensure that all front panel connections are secure. All SMA 
connections should be tightened to 100 N-cm using a standard SMA 
torque wrench. Loose connections can impair instrument operation.

3. Launch MAX by navigating to Start»Programs»
National Instruments»Measurement & Automation or by clicking 
the MAX desktop icon, shown at left.

4. Navigate to the Device and Interfaces»NI-DAQmx Devices folder.

5. Right-click NI PXI-5610 and select Properties, as shown in 
Figure B-1. 

Figure B-1.  Select Properties from the NI PXI-5610 Right-Click Menu
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6. In the NI 5610 Device Properties dialog, verify that the proper NI 5421 
AWG module (that is, the one interconnected to the NI 5610 
upconverter module) is associated as shown in Figure B-2.

Figure B-2.  The NI PXI-5610 Device Properties Dialog Displays the Associated AWG

7. If this panel does not show an NI 5421 AWG module associated with 
the NI 5610, right-click the drop-down listbox to select an available 
NI 5421 AWG module to associate as shown in the Configuring the 
NI 5670 Modules in MAX section of Chapter 1, Getting Started with 
the NI 5670.

8. When the correct NI 5421 AWG module is specified, click OK to 
return to MAX.
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9. In the MAX Configuration tree, right-click NI PXI-5610 and select 
Test Panels as shown in Figure B-3. 

Figure B-3.  Open the NI 5670 Test Panel from the NI PXI-5610 Right-Click Menu
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10. In the Test Panels window, click the NI PXI-5610 tab to view the 
NI 5610 test panel shown in Figure B-4. 

Figure B-4.  Click the NI PXI-5610 Tab to View the Upconverter Module Test Panel

11. The NI PXI-5610 tab verifies PLL locking and proper functioning of 
the upconverter hardware. Specify center frequency and gain settings. 

12. Click Start to run the NI 5610 upconverter test panel.

Tip Running the test panel outputs a signal from the RF OUTPUT front panel connector. 
Disconnect any equipment that may be damaged by the test signal.
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13. During operation of the test panel, the ACTIVE LED on the NI 5610 
upconverter module front panel is illuminated, and the test panel is 
displayed as shown in Figure B-5.

Figure B-5.  The NI 5670 Test Panel during Operation

14. Click Stop to halt upconverter operation.

15. If the NI 5610 test panel generates an error, power off your system and 
reinstall the RF Vector Signal Generator software and hardware.

If the NI 5610 test panel does not generate an error, continue with the 
following steps:

16. Click the NI PXI-5670 tab to return to the NI 5670 test panel.

17. Click Start in the NI 5670 test panel to begin waveform generation and 
verify proper operation. 

18. Click Stop to halt signal generation and Close to return to the MAX 
main window.
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If the NI 5670 test panel generates errors after successful operation of the 
NI 5610 test panel, complete steps 19 through 22.

19. In the MAX Configuration tree, right-click NI PXI-5421 and select 
Test Panels as shown in Figure B-6. 

Figure B-6.  Open the NI 5421 Test Panel from the NI PXI-5421 Right-Click Menu
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20. The NI 5421 test panel (Figure B-7) verifies intermediate frequency 
(IF) signal generation capabilities. Specify a center frequency in the 
Waveform Frequency (Hz) control. 

Figure B-7.  The NI PXI-5421 AWG Module Test Panel

21. Click Start to run the NI 5421 AWG module test panel.



Appendix B Troubleshooting

NI 5670 RF Vector Signal Generator Getting Started Guide B-10 ni.com

During operation of the test panel, the test panel is displayed as shown in 
Figure B-8.

Figure B-8.  The NI 5421 Test Panel during Operation

22. Click Stop to halt IF signal generation.

If the NI 5421 test panel generates an error, complete steps 23 through 29:

23. Power off your PXI chassis.

24. Disconnect the NI 5670 module front panel coaxial cables. 

25. Remove and reinstall your NI 5421 AWG hardware module.

26. Reconnect the NI 5670 front panel cables securely as shown in the 
Interconnecting NI 5670 Modules section of Chapter 1, Getting 
Started with the NI 5670. 
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27. Power on your system and run the self-test and MAX test panel 
procedures in the Configuring the NI 5670 Modules in MAX section of 
Chapter 1, Getting Started with the NI 5670.

28. If failures continue, contact NI technical support at ni.com/ask or 
call 866-275-6964 and ask to speak to a customer service 
representative. 
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C
Technical Support and 
Professional Services

Visit the following sections of the National Instruments Web site at 
ni.com for technical support and professional services:

• Support—Online technical support resources include the following:

– Self-Help Resources—For immediate answers and solutions, 
visit our extensive library of technical support resources available 
in English, Japanese, and Spanish at ni.com/support. These 
resources are available for most products at no cost to registered 
users and include software drivers and updates, a KnowledgeBase, 
product manuals, step-by-step troubleshooting wizards, 
conformity documentation, example code, tutorials and 
application notes, instrument drivers, discussion forums, 
a measurement glossary, and so on.

– Assisted Support Options—Contact NI engineers and other 
measurement and automation professionals by visiting 
ni.com/support. Our online system helps you define your 
question and connects you to the experts by phone, discussion 
forum, or email.

• Training—Visit ni.com/training for self-paced tutorials, videos, 
and interactive CDs. You also can register for instructor-led, hands-on 
courses at locations around the world.

• System Integration—If you have time constraints, limited in-house 
technical resources, or other project challenges, NI Alliance Program 
members can help. To learn more, call your local NI office or visit 
ni.com/alliance.

• Declaration of Conformity (DoC)—A DoC is our claim of 
compliance with the Council of the European Communities using 
the manufacturer’s declaration of conformity. This system affords 
the user protection for electronic compatibility (EMC) and product 
safety. You can obtain the DoC for your product by visiting 
ni.com/hardref.nsf.
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• Calibration Certificate—If your product supports calibration, 
you can obtain the calibration certificate for your product at 
ni.com/calibration.

If you searched ni.com and could not find the answers you need, contact 
your local office or NI corporate headquarters. Phone numbers for our 
worldwide offices are listed at the front of this manual. You also can visit 
the Worldwide Offices section of ni.com/niglobal to access the branch 
office Web sites, which provide up-to-date contact information, support 
phone numbers, email addresses, and current events.
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